Película duplicadas en videoteca de alfa

11 Dic 2018
52
2
8
40
#1
Pues resulta q dentro de la videoteca de alfa,un montón de películas me salen duplicadas. Y cada una con sus correspondientes enlaces,es decir,los mismos en una y otra. Acabo de meterme en el gestor de archivos y resulta q las q están duplicadas,a parte de los archivos .json .strm y .nfo con el nombre de la película,hay otro archivo q se llama tvshow.nfo. Lo borro y se vuelve a añadir solo. Supongo a el problema viene de ahí,ya q no me cuadra un archivo de series o tvshow dentro de una película. Además,sale en las q están duplicadas y en las otras no. Alguien que me pueda ayudar??
 

Delta

Miembro del equipo
16 Oct 2017
637
715
93
#2
Necesitaremos mas informacion sobre el problema, canales desde donde agregas, algun ejemplo, si el problema es actual adjunta el log detallado que obtienes luego de agregar una pelicula y que se produzca dicha duplicacion.

Saludos
 
11 Dic 2018
52
2
8
40
#3
Necesitaremos mas informacion sobre el problema, canales desde donde agregas, algun ejemplo, si el problema es actual adjunta el log detallado que obtienes luego de agregar una pelicula y que se produzca dicha duplicacion.

Saludos
Ok. Perdón,voy a explicarme porque estoy desesperado ya con el tema. Lo de la duplicación en sí,no es q fuese un problema para mi,ya q en la videoteca de kodi,q es de donde veo las pelis y series no estaban duplicadas. Solo pasaba en la videoteca de alfa. Pero claro me olía muy mal,y el problema es bastante más gordo. A ver si me explico bien; Los canales q uso en alfa son dos básicamente. Newpct1 y gran torrent. Digamos q 95% newpct1, 3% gran torrent y el 2% de seriesdanko,por alguna serie menos conocida. En el kodi en general solo uso alfa y plexus(con el avezy),y eso q llevo muchos años y he probado toneladas de addons. Por eso ,me tiene loco tener problemas con alfa. En las películas q había duplicadas coincidía q en todas había un archivo tvshow.nfo,y en el resto no. Supongo q podía ser un conflicto con los proveedores de información. Pero de repente me di cuenta de q aunque la videoteca de alfa se actualizaba( las series q yo tenGo marcadas q se actualicen) pero después no se transferían a la colección de kodi. Yo le daba a actualizar coleccion( la de kodi,no la de alfa) y no me actualizaba nada. Pues bueno,probé a desinstalar alfa e instalarlo,pero no se borraban los ajustes,y no me pedía auto-configurar la videoteca. Pues probé a borrar las carpetas de alfa,y entonces si q al instalarlo y configurar,me auto configuraba la videoteca. Vale genial,añadía pelis y series de newpct1 y se añadian a la videoteca de alfa y después a la colección de kodi. Probaba a copiar a las carpetas de alfa directamente las pelis y series q tenía guardadas y las leía correctamente. Pero resulta q al reiniciar y volver a probar,ya no se “sincronizaban” las videoteca de alfa y kodi. Me tire toda la noche loco,repitiendo la operación no se cuantas veces,incluso restaurando copias de seguridad de hace meses y nada. Tras mucho mirar y volverme loco,en el menú de vídeos/archivos yo tengo añadidas un par de carpetas de de series y pelis de el disco duro q tengo conectado. Pues cuando instalaba en limpio alfa añadía todo bien,como había comentado,y las bibliotecas se sincronizaban. En ese menu de archivos,solo estaban las carpetas del disco duro,pero resulta q al reiniciar y cuando se perdía la sincronización,resulta q en ese menú apracian como fuentes,la carpeta de alfa donde se descargan las pelis y otra q pone downloads y dentro list. Yo juraría q eso nunca había sido así,y q solo tenia ahí las carpetas del disco duro. No se si me he explicado bien,pero la cuestión es q estoy ahora con el alfa q no se sincroniza con la colección de kodi,y coincide q cuando deja de funcionar es cuando apracen esas carpetas. Espero q me podáis ayudar,porque es algo q uso todos los días para ver series y ahora no se como solucionarlo. Ya me tire la noche de ayer haciendo 20 veces lo mismo y esto desesperado. Lo del log,puedo sacarlo pero no se cuando. Intentando añadir una serie a la videoteca? Eso lo hace bien,y según lo instalo,la sincronizacion con la videoteca ( o colección) de kodi tb. Pero al reiniciar es cuando se jode y aparecen esas carpetas en el menú de vídeo/archivos. No se,creo q no me puedo explicar mejor. Lo siento si no se me entiende. Pero ojalá me podáis ayudar...ahhh,también alguna de las veces q lo instalaba en limpio y la principio todo iba bien,al reiniciar,se actualizaba la videoteca de kodi,pero iba pasándo por los nombres de las series,pero sin pararse a buscar en ninguna. Es decir,yo tengo configuradas las q están en emisión q se actualicen automáticamente y las otras no. Las q se actualizan paran buscando en el canal en el q lo tengo añadido y las q no,simplemente aparece el nombre pero no se para en ellas. Y a a veces,al reimiciar me pasaba eso. Pero bueno,la mayoría de lás veces,si q actualizaba las q yo tengo señaladas en alfa,pero después no se pasaban a la colección de kodi.
 

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#4
Lo que comentas es complicado de entender desde fuera. Puede que tengas más de un problema. Para tratar de entender la verdadera dimensión de los problemas, vamos a ir por partes. En primer lugar nos vas a enviar un log, según las normas, que recoja todas las actividades desde el inicio de Kodi hasta que termine de actualizar la videoteca de Alfa, incluso un par de minutos más. También, necesitamos que hagas un Zip/Rar de toda la carpeta y subcarpetas de la Videoteca de Alfa.

Una vez que hayas suministrado esta documentación, veremos si es necesario realizar más pruebas.
 
11 Dic 2018
52
2
8
40
#5
Lo que comentas es complicado de entender desde fuera. Puede que tengas más de un problema. Para tratar de entender la verdadera dimensión de los problemas, vamos a ir por partes. En primer lugar nos vas a enviar un log, según las normas, que recoja todas las actividades desde el inicio de Kodi hasta que termine de actualizar la videoteca de Alfa, incluso un par de minutos más. También, necesitamos que hagas un Zip/Rar de toda la carpeta y subcarpetas de la Videoteca de Alfa.

Una vez que hayas suministrado esta documentación, veremos si es necesario realizar más pruebas.
Ok. El problema es que no se como hacer para q en el log se muestre q tengo dos películas de cada. El problema del duplicado m,estoy seguro q es de los archivos q hay dentro de cada peli,es decir los .json .srtm .nfo,porque el q me sobra de todas las duplicadas es el de tvshow.nfo. Q en las series es lógico q este,pero en las pelis creo q es lo q sobra. Os podría mandar como comentas un .zip de la videoteca de alfa( las carpetas series y cine),q así podríais ver la estructura de archivos a la q me refiero. En cuanto llegue a casa( en media hora) lo hago.
Respecto al otro tema,de q no actualice,desde la última copia de seguridad q restaure,no me había vuelto a fallar. Supongo de tanto andar desinstalando y borrando,alguna pifia armé. Si me vuele a fallar la actualización de la q llegue a casa mando,como también comentas,el log que recoja las actividades mientras actualizo y demás. En un momento lo hago. Y muchas gracias de antemano por el interés. Ya digo q este addon para mi es fundamental...
 

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#6
Por eso te pedimos que nos envíes toda la Videoteca Alfa en un .zip/rar, para entender como está la estructura de los archivos. Para empezar, las películas no tiene tvshow.nfo, como bien dices. Si lo borras, no debería aparecer de nuevo (sin entender cómo ha llegado ahí). Incluso, si lo borras en una serie, la serie queda inutilizada en la Videoteca.
 
11 Dic 2018
52
2
8
40
#7
Por eso te pedimos que nos envíes toda la Videoteca Alfa en un .zip/rar, para entender como está la estructura de los archivos. Para empezar, las películas no tiene tvshow.nfo, como bien dices. Si lo borras, no debería aparecer de nuevo (sin entender cómo ha llegado ahí). Incluso, si lo borras en una serie, la serie queda inutilizada en la Videoteca.
tienes toda la razón. Ya estoy en casa y por lo que veo,el problema de no actualizar fue alguna pifia mía por tanto trastear. Dejo el adjunto de un zip de la carpeta que contiene la biblioteca de Alfa.
Efectivamente,yo q no tengo mucha idea,supuse por lógica que no pinta nada un archivo de info de series en una peli...y probé a borrarlos pero vuelven a salir. Mas o menos como las almorranas!!! A ver si hay suerte y lográis descifrar el entuerto. eso si,solo he podido meter como tres o cuatro series y unas pocas peliculas,en .rar de 1mb no me daba para mas...
 

Adjuntos

17 Sep 2018
51
5
8
29
#8
Ok. El problema es que no se como hacer para q en el log se muestre q tengo dos películas de cada. El problema del duplicado m,estoy seguro q es de los archivos q hay dentro de cada peli,es decir los .json .srtm .nfo,porque el q me sobra de todas las duplicadas es el de tvshow.nfo. Q en las series es lógico q este,pero en las pelis creo q es lo q sobra. Os podría mandar como comentas un .zip de la videoteca de alfa( las carpetas series y cine),q así podríais ver la estructura de archivos a la q me refiero. En cuanto llegue a casa( en media hora) lo hago.
Respecto al otro tema,de q no actualice,desde la última copia de seguridad q restaure,no me había vuelto a fallar. Supongo de tanto andar desinstalando y borrando,alguna pifia armé. Si me vuele a fallar la actualización de la q llegue a casa mando,como también comentas,el log que recoja las actividades mientras actualizo y demás. En un momento lo hago. Y muchas gracias de antemano por el interés. Ya digo q este addon para mi es fundamental...
Las peliculas que vez duplicadas es porque borraste las peliculas desde la videoteca o archivos y no de la biblioteca, pero en realidad de las 2 solo funciona una y al intentar reproducir te dice que no existe y te pide borrarla, pero en caso de que sean muchas peliculas o series duplicadas solo debes ir a ajustes, luego a multimedia y ponerlo en modo experto, entonce darle a biblioteca y alli darle donde dice limpiar libreria y eso quitara todo lo duplicado...
 

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#9
El problema es más complejo de lo previsto. Hay un error en Alfa que tenemos que identificar y corregir. De momento no toques más ni hagas más pruebas. Esperamos responderte positivamente en poco tiempo.
 
11 Dic 2018
52
2
8
40
#10
Las peliculas que vez duplicadas es porque borraste las peliculas desde la videoteca o archivos y no de la biblioteca, pero en realidad de las 2 solo funciona una y al intentar reproducir te dice que no existe y te pide borrarla, pero en caso de que sean muchas peliculas o series duplicadas solo debes ir a ajustes, luego a multimedia y ponerlo en modo experto, entonce darle a biblioteca y alli darle donde dice limpiar libreria y eso quitara todo lo duplicado...
Y no crees q ya probé a abrir los dos? Llevo días con el problema y soy usuario de kodi desde antes q se llamase kodi(XBMC),o sea,muuuchos años. Te aseguro q cuando hago una pregunta de estas,es porque me he tirado muchas horas antes,intentando solucionarlo. Lo q tú dices me ha pasado muchas veces y esto no tiene q ver. Son dos películas duplicadas con los mismo enlaces y funcionando igual. Y el hecho de q las duplicadas tengan un archivo de información sobre series ( tvshow.nfo) y q aunque lo borres se vuelva a crear solo,es una buena pista para indagar sobre ello. Pero eso ya qda en los expertos de alfa,q son unos cracks. Gracias por la respuesta de todas formas...
 
11 Dic 2018
52
2
8
40
#11
El problema es más complejo de lo previsto. Hay un error en Alfa que tenemos que identificar y corregir. De momento no toques más ni hagas más pruebas. Esperamos responderte positivamente en poco tiempo.
Como puse en el mensaje anterior,no soy nuevo con el kodi,y con LibreElec llevo un año,y ya lo controlo bastante bien. Nunca me había pasado esto y eso q de la copia de seguridad q tengo,les he montando a varios familiares y amigos un equipo como el mío (s905x + LibreElec) y están todos encantados,y no son expertos ni nada de eso. Lo de estos días estoy seguro q no es normal. Aunque ahora me actualiza,hay algo q no me cuadra bien y no se q es. No se si tiene q ver con los proveedores de información ( tvdb,tmdb) q tengan algun error de sincronización y le metan a películas información sobre series ( tvshow.nfo). Después hay otra cosa q no me cuadra y podría tener q ver con la duplicación y con el error de actualización. Lo expliqué en el otro mensaje,pero no lo hice bien;
Estoy casi seguro de q en el menú principal dé kodi de vídeos/archivos,las únicas fuentes q deberia de haber ahí,son las fuentes q añada mano,para decirle al kodi q en esas fuentes tengo pelis o series,es decir,yo tengo un disco duro con toneladas de series y pelis conectado siempre al kodi. Al conectarlo la primera vez,para añadirlo,me metía en vídeos/archivos y ahí añado la carpeta del disco donde tengo series y le digo al kodi q en esa carpeta hay series y q utilice el proveedor de series( tvdb) y el idioma y demás. Y con la carpeta donde tengo pelis lo mismo,pero con el proveedor de pelis( tmdb). Por lo que yo en ese menú lo único q tenia son esas dos carpetas( Pelis y series)y juraría q nunca había ninguna otra carpeta ahí,ya q para ver una par de series documentales,tenia q meterme en archivos/series porque kodi no las detectaba para la colección principal. Y casi q apostaría q cuando me metía en archivos y vídeos,esas eran las únicas carpetas. Dicho lo cual,puedo estar seguro y en realidad confundirme.
O sea,q igual se me esta yendo la pinza con esto. Pero la cuestión es q ahora aparte de las dos carpetas (o fuentes) del disco duro,ahora aparece otra con la dirección donde esta la videolibrary de alfa. Y si estuviese en lo cierto,entonces puede q estuviese tirando de dos fuentes a la vez ( desde la videoteca de alfa,y desde esa carpeta De Fuentes) y por lo tanto es lógico q saliesen duplicadas. Lógicamente probé a borrar esa fuente,y lógicamente se me borraba toda la videoteca de alfa y por ende,de Kodi. Tenia q desinstalar alfa y borrar sus carpetas,para instalar de 0 alfa y q me autoconfigurase la videoteca de alfa con kodi. Si lo q hace es precisamente añadir esa fuente,y es algo q siempre fue así,entonces es q stop confundido. Si no,pues igual puede ir por ahí la cosa. Lo digo por intentar dar alguna idea,aunque seguramente sean absurdas.Sea como sea,seguro q dais con el problema.
El otro tema q había escrito por aquí era porque se me qdaba pillado al añadir series y pelis a la videoteca. Resulta q era la nueva función de cacheo de torrentes para hacer respaldos,y os había comentado q estaría bien ver el progreso en la ventana de añadir a videoteca,y ahora ya lo habéis puesto. No lo usaba pero ahora con grantorrent si q lo uso,q es una pagina( canal) q falla bastante. Mis felicitaciones,sois unos cracks. Espero q sigáis así,y se me solucione lo del alfa,porque ya digo q es el único addon q uso( junto con la dupla
Plexus/avezy),y debí probar docenas y docenas de addons a lo largo de los años...
 
Última edición:

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#12
Hola, vamos a ver si tengo buenas noticias...

Por ahora he identificado dos problemas, ambos relacionados con la migración automática realizada hace unas semanas para cachear enlaces y torrents. Estos problemas no ocurren cuando se añade una nueva serie o película a la Videoteca:

1.- Aparece un archivo Tvshow.nfo en cada carpeta de las películas de la Videoteca. Un error ridículo, que no ocasionaba ningún efecto secundario más allá de lo estético

2.- Duplica las películas. De nuevo el error era una tontería, pero los efectos causados son bastante serios. Cuando existían películas (no series) con dos o más canales añadidos, clones de Newpct1, los valores de la películas del primer clone machacaban al de los restantes clones, por lo que parecen que son la misma película duplicada, pero en realidad es una película con dos o más enlaces de otros clones, con diferentes calidades.

Los dos problemas están ya resueltos. Reparar los daños causados por el segundo error, va a llevar un rato más. Recuerda que este problema que te ocurre a ti puede estar pasando a otros usuarios.

En lo que respecta a las series, no veo ningún error consecuencia de Alfa, pero sí veo inconsistencias. Yo apuntaría a la intervención humana, quizás con la gestión de los backups. Por ejemplo, en El Cuento de la Criada tienes los archivos de dos canales, pero en el tvshow.nfo solo apunta a descargas2020.com y no a grantorrent.com. Ambos canales te aparecen cuando vas a ver un episodio, pero los episodios de grantorrent nunca se actualizaran.

Para las series que veas inconsistentes, te sugiero que las borres de la videoteca de Alfa y las vuelvas a añadir.
 
11 Dic 2018
52
2
8
40
#13
Hola, vamos a ver si tengo buenas noticias...

Por ahora he identificado dos problemas, ambos relacionados con la migración automática realizada hace unas semanas para cachear enlaces y torrents. Estos problemas no ocurren cuando se añade una nueva serie o película a la Videoteca:

1.- Aparece un archivo Tvshow.nfo en cada carpeta de las películas de la Videoteca. Un error ridículo, que no ocasionaba ningún efecto secundario más allá de lo estético

2.- Duplica las películas. De nuevo el error era una tontería, pero los efectos causados son bastante serios. Cuando existían películas (no series) con dos o más canales añadidos, clones de Newpct1, los valores de la películas del primer clone machacaban al de los restantes clones, por lo que parecen que son la misma película duplicada, pero en realidad es una película con dos o más enlaces de otros clones, con diferentes calidades.

Los dos problemas están ya resueltos. Reparar los daños causados por el segundo error, va a llevar un rato más. Recuerda que este problema que te ocurre a ti puede estar pasando a otros usuarios.

En lo que respecta a las series, no veo ningún error consecuencia de Alfa, pero sí veo inconsistencias. Yo apuntaría a la intervención humana, quizás con la gestión de los backups. Por ejemplo, en El Cuento de la Criada tienes los archivos de dos canales, pero en el tvshow.nfo solo apunta a descargas2020.com y no a grantorrent.com. Ambos canales te aparecen cuando vas a ver un episodio, pero los episodios de grantorrent nunca se actualizaran.

Para las series que veas inconsistentes, te sugiero que las borres de la videoteca de Alfa y las vuelvas a añadir.
Joder,así da gusto. Efectivamente,el problema de duplicado solo ocurría con las q copiaba a la carpeta de la videoteca de alfa,desde mi disco duro. Como dije,podía ser parte pifia mia,porque ya te digo q desinstale alfa un montón de veces e incluso restaure una par de veces la copia de seguridad q tengo de LibreElec,q restaura sistema,kodi y todo su contenido. La serie q me dices por ejemplo la copié con las demás del disco duro,pero ya la había visto y la había borrado,de ahí q al volver a copiarse entre las demás,podrian verse errores en esa y alguna mas. Pero esas series fui borrándolas ya desde la videoteca,ya q ya las he visto,. En eso no hay problema.
Respecto a lo de los duplicados entiendo q ya no ocurrirá más? los q ya tengo hay manera de borrarlos?? Borrando los archivos tvshow.nfo? O directamente borrando la película y volviendo a añadirla desde el canal correspondiente?Tampoco me preocupa,ya q ocurre solo ocurre dentro de la videoteca de alfa,y yo siempre veo las pelis y series dese la videoteca principal de Kodi. Era mas q nada para dar ideas de por donde podían venir todos los problemas q estaba teniendo. Como me imaginaba era mitad pifia mia y mitad pifia ajena a mis manazas...sea como sea. Muchas gracias de nuevo...
 

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#14
Estoy preparando un convertidor para reparar las películas averiadas. En la nuevas que añadas ya no ocurrira. Cómo no sé a cuántos usuarios ha afectado, tengo que regenerarlas automáticamente. El cambio no es simple, no solo consiste el borrar el Tvshow.nfo, que es lo fácil. Espero que mañana esté todo listo.

Gracias por tu paciencia. Saludos.
 
11 Dic 2018
52
2
8
40
#15
Estoy preparando un convertidor para reparar las películas averiadas. En la nuevas que añadas ya no ocurrira. Cómo no sé a cuántos usuarios ha afectado, tengo que regenerarlas automáticamente. El cambio no es simple, no solo consiste el borrar el Tvshow.nfo, que es lo fácil. Espero que mañana esté todo listo.

Gracias por tu paciencia. Saludos.
En mi caso son como 20 películas,y ya te digo q no las voy ni a borrar porque no me molesta,mientras solo me pase en la videoteca de alfa,ya q no me suelo meter nunca. Si fuese en la videoteca principal de kodi,ya serie un engorro,pero vamos q por mi,con q me hayas aclarado el porqué de tanto lío,ya me quedo satisfecho. De verdad q da gusto como os lo curráis. Muchas gracias


Enviado desde mi iPhone utilizando Tapatalk
 

Kingbox

Miembro del equipo
24 Oct 2017
601
208
43
Madrid
#16
Ta está resuelto el problema con las películas duplicadas. No sólo evita el problema de cara al futuro, sino que repara la Videoteca de CINE totalmente.

Debes reiniciar Kodi, esperar a que actualice la Videoteca, y por seguridad repetir este proceso otra vez.

Ya nos contarás el resultado. Saludos.
 
'Me Gusta': Fermin
11 Dic 2018
52
2
8
40
#17
Ta está resuelto el problema con las películas duplicadas. No sólo evita el problema de cara al futuro, sino que repara la Videoteca de CINE totalmente.

Debes reiniciar Kodi, esperar a que actualice la Videoteca, y por seguridad repetir este proceso otra vez.

Ya nos contarás el resultado. Saludos.
Pues acabo de encender el aparato,y a la primera actualización...arreglado!!! Eres un crack. Miles de gracias por la implicación y la rapidez...


Enviado desde mi iPhone utilizando Tapatalk
 
'Me Gusta': Kingbox