Manual de Alfa Assistant (herramienta de apoyo)

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
Hola, varias cosas de tu log:
- el log tiene más de 57.000 líneas, de la cuales la gran mayoría son de un mensaje repetitivo generado por el addon:
AddOnLog: pvr.iptvsimple: pvr.iptvsimple - LoadEPG - EPG file path is not configured. EPG not loaded.
Míralo, porque puede estar impactando a todo el Kodi, además de que es dificilísimo encontrar algo.

- El archivo de la BBDD de la videoteca de Kodi está obsoleto. Tienes el MyVideos116.db cuando debería ser el MyVideos119. Si están los dos, borra el /storage/.kodi/userdata/Database/MyVideos116.db

- La buena noticia es que Alfa Assistant está funcionando bien y genera la cookie especial necesaria para que HDFull pueda hacer login. La mala noticia es que el módulo de Kodi responsable de acceder a la página de HDFull ignora esa cookie. Desde el punto de vista de Alfa el proceso es sencillo: después de conseguir la cookie se añade al fichero de cookies y ya está. El resto es automático hasta que caduca la cookies (dura pocos minutos) y vuelta a empezar.

Una posibilidad es que el archivo de cookies de Alfa esté corrupto. Bórralo y prueba de nuevo: /storage/.kodi/userdata/addon_data/plugin.video.alfa/cookies.dat

Si no se arregla, envíame el archivo de cookies después de intentar un acceso a HDFull, para ver si está la cookies especial, junto con el log de la prueba
 
  • Me gusta
Reacciones: Cylon

JoSHiKo

Usuario Novato
21 Ene 2018
11
0
1
39
Hola, varias cosas de tu log:
- el log tiene más de 57.000 líneas, de la cuales la gran mayoría son de un mensaje repetitivo generado por el addon:
AddOnLog: pvr.iptvsimple: pvr.iptvsimple - LoadEPG - EPG file path is not configured. EPG not loaded.
Míralo, porque puede estar impactando a todo el Kodi, además de que es dificilísimo encontrar algo.

- El archivo de la BBDD de la videoteca de Kodi está obsoleto. Tienes el MyVideos116.db cuando debería ser el MyVideos119. Si están los dos, borra el /storage/.kodi/userdata/Database/MyVideos116.db

- La buena noticia es que Alfa Assistant está funcionando bien y genera la cookie especial necesaria para que HDFull pueda hacer login. La mala noticia es que el módulo de Kodi responsable de acceder a la página de HDFull ignora esa cookie. Desde el punto de vista de Alfa el proceso es sencillo: después de conseguir la cookie se añade al fichero de cookies y ya está. El resto es automático hasta que caduca la cookies (dura pocos minutos) y vuelta a empezar.

Una posibilidad es que el archivo de cookies de Alfa esté corrupto. Bórralo y prueba de nuevo: /storage/.kodi/userdata/addon_data/plugin.video.alfa/cookies.dat

Si no se arregla, envíame el archivo de cookies después de intentar un acceso a HDFull, para ver si está la cookies especial, junto con el log de la prueba
Muchas gracias, he desinstalado el addon simpleiptv y borrado el archivo de cookies.

He mirado la base de datos y aparece la 119 y la 116 aparece como old (adjunto pantallazo)

Tras probar sigue sin funcionar. Este es el contenido del archivo de cookies (falta la primera cabecera comentada del netscape...):

Código:
# http://curl.haxx.se/rfc/cookie_spec.html
# This is a generated file!  Do not edit.

.anonfiles.com  TRUE    /       TRUE    1668290450      USERSESSID      eyJpdiI6Im5YQ1lTZFFmWTVHcHk2aXphSXdzNmc9PSIsInZhbHVlIjoiY2dOck5UWm4yKzNiXC84c1wvWjVORlFseTlybjdqZXFvU2VvdzEwbGZzd2Y5YVVhVFwvNXMyYUEyUGtZK3B5TDZxRSIsIm1hYyI6Ijc3YWQ4MGI0M2E5NzVmYWE5Y2NhNmVmMjhhMWU1NTY4MjJhN2QyNjgzOTllMWI4ODlmNDBkZGY1NmMxYjc5NWYifQ%3D%3D
.hdfull.digital TRUE    /       FALSE   1668373224      cf_clearance    2JzeAU3DmCHZ5f72KebsxNaIFVnqgrRqlHG.v.bHBLc-1668286822-0-150
Y aquí esta el log de la ejecución:

 

JoSHiKo

Usuario Novato
21 Ene 2018
11
0
1
39
Muchas gracias, he desinstalado el addon simpleiptv y borrado el archivo de cookies.

He mirado la base de datos y aparece la 119 y la 116 aparece como old (adjunto pantallazo)

Tras probar sigue sin funcionar. Este es el contenido del archivo de cookies (falta la primera cabecera comentada del netscape...):

Código:
# http://curl.haxx.se/rfc/cookie_spec.html
# This is a generated file!  Do not edit.

.anonfiles.com  TRUE    /       TRUE    1668290450      USERSESSID      eyJpdiI6Im5YQ1lTZFFmWTVHcHk2aXphSXdzNmc9PSIsInZhbHVlIjoiY2dOck5UWm4yKzNiXC84c1wvWjVORlFseTlybjdqZXFvU2VvdzEwbGZzd2Y5YVVhVFwvNXMyYUEyUGtZK3B5TDZxRSIsIm1hYyI6Ijc3YWQ4MGI0M2E5NzVmYWE5Y2NhNmVmMjhhMWU1NTY4MjJhN2QyNjgzOTllMWI4ODlmNDBkZGY1NmMxYjc5NWYifQ%3D%3D
.hdfull.digital TRUE    /       FALSE   1668373224      cf_clearance    2JzeAU3DmCHZ5f72KebsxNaIFVnqgrRqlHG.v.bHBLc-1668286822-0-150
Y aquí esta el log de la ejecución:

 

Adjuntos

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
El log sigue con el mismo problema de mensajes "basura" tienes 386.000 mensajes diciendo "UpdateFromScraper: No EPG scraper defined for table ". Obviamente tienes algo en Kodi metido en un bucle.

En el archivo de cookies aparece la cookie obtenida por Alfa Assistant, pero no aparece la cookie estándar de HDFull. La generación de esa cookie es estándar de Kodi.

Tengo una vieja RPi3 con LibreElec 10.0.2. He probando y funciona perfectamente. No veo que sea un problema del entorno Alfa. Te sugiero que mires el resto del "ecosistema" de Kodi, incluso que pruebes con una instalación limpia de Kodi con solo Alfa instalado.
 

JoSHiKo

Usuario Novato
21 Ene 2018
11
0
1
39
El log sigue con el mismo problema de mensajes "basura" tienes 386.000 mensajes diciendo "UpdateFromScraper: No EPG scraper defined for table ". Obviamente tienes algo en Kodi metido en un bucle.

En el archivo de cookies aparece la cookie obtenida por Alfa Assistant, pero no aparece la cookie estándar de HDFull. La generación de esa cookie es estándar de Kodi.

Tengo una vieja RPi3 con LibreElec 10.0.2. He probando y funciona perfectamente. No veo que sea un problema del entorno Alfa. Te sugiero que mires el resto del "ecosistema" de Kodi, incluso que pruebes con una instalación limpia de Kodi con solo Alfa instalado.
He reiniciado la rpi ya por probar y ahora ha funcionado! Gracias! No hay ninguna opción para portar el assistant a Libreelec ?
 

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
He reiniciado la rpi ya por probar y ahora ha funcionado! Gracias! No hay ninguna opción para portar el assistant a Libreelec ?
Puede que a Linux algún día, pero a LibreElec poco menos que imposible debido a la poca funcionalidad del sistema operativo
 
  • Me gusta
Reacciones: Cylon

Cylon

Miembro del equipo
31 Ago 2018
26
2
3
He reiniciado la rpi ya por probar y ahora ha funcionado! Gracias! No hay ninguna opción para portar el assistant a Libreelec ?
La versión para Linux/Win/Mac sigue en etapa muy temprana de test interno de un mínimo de funcionalidades. Como dice Kingbox la versión para Libreelec sería un tema complicado debido a ese SO tan especial. Pero bueno todo dependerá de cómo evoluciona en los otros 3 SO, por de pronto a casi nadie parece importarle usarlo fuera de Android...
 

hobbes

Usuario
18 Nov 2017
105
19
18
Creo que he hecho todo bien, pero no consigo que me funcione. Cuando intento entrar a Dilo en el assistant se me enciende la lucecita verde de test, pero en alfa no me aparece ningun enlace. Tampoco me entra en Hdfull, pero como ahi he estado haciendo "experimentos" no me sorprenderia haber roto algo.

Adjunto el log
 

Adjuntos

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
Con Dilo no creo que ayude el Assistant, pero con HDFull sí. De todas formas he hecho un cambio para que vaya menos mal. Actualiza la versión de Alfa
 
  • Me gusta
Reacciones: hobbes

hobbes

Usuario
18 Nov 2017
105
19
18
Con Dilo no creo que ayude el Assistant, pero con HDFull sí. De todas formas he hecho un cambio para que vaya menos mal. Actualiza la versión de Alfa
Muchas gracias, con Dilo no he tenido tiempo de probarlo pero con HDFull si y ha funcionado bien.

Tengo una duda, no se si es asi o falla algo. Configuro el alfa assistant en kodi, otro dispositivo, pongo la ip, etc.. y guardo los cambios, pero al cabo de un rato se ponen solos como estaban, este disposivo, la ip vacia y tengo que volver a cambiarlo si lo quiero volver a usar.

Un saludo
 

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
Pues no es normal en absoluto. Te sugiero que dejes el debug de Alfa activado y hagas esa operación de nuevo. Cuando veas que has vuelto a perder la IP sacas el log y nos lo envías.
 
  • Me gusta
Reacciones: hobbes

hobbes

Usuario
18 Nov 2017
105
19
18
Bueno, pues en algun momento me ha vuelto a pasar, acabo de mirarlo y se habia desconfigurado. Adjunto el log, aunque no se si servira de mucho ya que otra cosa que me pasa es que aunque activo el log detallado, tambien se desactiva solo.
Si no sirve seguire pendiente a ver si consigo uno bueno.

Muchas gracias y un saludo.
 

Adjuntos

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
El comportamiento de tu rPI es bastante confuso. Algo raro pasa, pero no creo que sea "culpa" de Alfa. Vamos a ver lo que veo:

  • Cuando inicia la rPI dice que YA está instalada Alfa 3.8.4, PERO inicia el proceso típico de inicialización de versión que se hace JUSTO cuando se actualiza la versión, no en el siguiente reinicio de Kodi. La revisión que hace de los archivos de settings de Alfa es correcta, no hay ninguno estropeado ni reparado.
  • Esto me hace pensar que no solo te resetea el archivo de settings de Alfa, sino que resetea más cosas, por ejemplo el archivo de control de los fixes. Cuando se subió la versión 3.8.4, se subió poco después el primer fix, por tanto (casi) con toda seguridad al actualizar tu rPI a la versión 3.8.4 tendría que haber instalado inmediatamente el fix 1. No estaba instalado ninguno, o al menos no existía el archivo de control de los fixes.
  • La pregunta, ¿no tendrás instalado algún "limpiador mágico" o algún sistema de respaldo que haga lo que no debe?

Pasando a otros asuntos que veo en el log:
  • Tienes instalado el addon Track.tv, pero te dar un error con el token de autenticación
  • Veo que tienes instalado el Assistant. ¡Muy bien! Aunque está funcionando bien y captura lo que debe de HDFull y de Dilo, el entorno de seguridad SSL que tienes implantado hace que realmente no se usen esos valiosos datos obtenidos. Eso hace que intente la vía alternativa de acceder con proxies inestables y lentos. Funciona a veces, pero falla más de lo aceptable.
  • La solución es que pases a Kodi 19 o 20 donde el entorno de seguridad SSL es el requerido por webs como las de HDFull y Dilo. Entonces sí le sacarás partido al Assistant, experimentado un aumento importante de velocidad y estabilidad.
  • También pasando a Kodi 19 o Kodi 20, igual se arregla el problema "fantasma" del reseteo de los ajustes de Alfa
 
  • Me gusta
Reacciones: hobbes

hobbes

Usuario
18 Nov 2017
105
19
18
El comportamiento de tu rPI es bastante confuso. Algo raro pasa, pero no creo que sea "culpa" de Alfa. Vamos a ver lo que veo:

  • Cuando inicia la rPI dice que YA está instalada Alfa 3.8.4, PERO inicia el proceso típico de inicialización de versión que se hace JUSTO cuando se actualiza la versión, no en el siguiente reinicio de Kodi. La revisión que hace de los archivos de settings de Alfa es correcta, no hay ninguno estropeado ni reparado.
  • Esto me hace pensar que no solo te resetea el archivo de settings de Alfa, sino que resetea más cosas, por ejemplo el archivo de control de los fixes. Cuando se subió la versión 3.8.4, se subió poco después el primer fix, por tanto (casi) con toda seguridad al actualizar tu rPI a la versión 3.8.4 tendría que haber instalado inmediatamente el fix 1. No estaba instalado ninguno, o al menos no existía el archivo de control de los fixes.
  • La pregunta, ¿no tendrás instalado algún "limpiador mágico" o algún sistema de respaldo que haga lo que no debe?

Pasando a otros asuntos que veo en el log:
  • Tienes instalado el addon Track.tv, pero te dar un error con el token de autenticación
  • Veo que tienes instalado el Assistant. ¡Muy bien! Aunque está funcionando bien y captura lo que debe de HDFull y de Dilo, el entorno de seguridad SSL que tienes implantado hace que realmente no se usen esos valiosos datos obtenidos. Eso hace que intente la vía alternativa de acceder con proxies inestables y lentos. Funciona a veces, pero falla más de lo aceptable.
  • La solución es que pases a Kodi 19 o 20 donde el entorno de seguridad SSL es el requerido por webs como las de HDFull y Dilo. Entonces sí le sacarás partido al Assistant, experimentado un aumento importante de velocidad y estabilidad.
  • También pasando a Kodi 19 o Kodi 20, igual se arregla el problema "fantasma" del reseteo de los ajustes de Alfa
Muchisimas gracias por todos los comentarios.

-Que yo sepa no, echare un ojo a todos los addons por si veo algo raro, pero intencionadamente no he instalado ningun limpiador, ni ningun sistema de respaldo. He procurado tener lo menos posible.

-Track.tv podria desinstalarlo, hace mucho que me dejo de funcionar y como HDFull marca todo no lo he echado de menos.

-Habia notado la lentidud que mencionas pero pense que era normal al usar el Assistant. He actualizdo pero todavia no he tenido tiempo de probarlo. Estare pendiente y actualizare el hilo con lo que vea.

De nuevo muchas gracias.
 

hobbes

Usuario
18 Nov 2017
105
19
18
Actualizo

-Con el Assistant instalado y abierto he podido entrar en Dilo a la primera, en HDFull me ha deslogeado la primera vez, pero las 2 siguientes bien.

-De momento parece que guarda los cambios.

-Al iniciar una pelicula me da error, al darle a aceptar en el mensaje se ha bloqueado y he tenido que desenchufar para reiniciar, la siguiente vez he dejado que empezase y un poco despues he dado atras en vez de aceptar y se ha visto bien. La pelicula ha sido Tron Legacy y el servidor Streamtape.

Adjunto el log

Un saludo.
 

Adjuntos

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
Ha mejorado porque parece que ya no hay resets de los ajustes, pero sigue el mismo problema de HDFull.

He probado en 8 diferentes entornos/plataformas y solo me ha fallado en uno, un Linux con Kodi 19. Lo curioso es que en una rPI que tengo con la versión 10.0.2 me ha ido bien. En cualquier caso he subido una corrección para el 8º entorno que fallaba y ahora todos van bien.

Por favor, con el debug de Alfa activado reinicia Kodi y haz una prueba tanto con HDFull como con Dilo. Después me envías el log aunque te parezca que funciona. También me envías el fichero /storage/.kodi/userdata/addon_data/plugin.video.alfa/cookies.dat

El problema con la reproducción de la película ya está resuelto.
 
  • Me gusta
Reacciones: hobbes

hobbes

Usuario
18 Nov 2017
105
19
18
Ha mejorado porque parece que ya no hay resets de los ajustes, pero sigue el mismo problema de HDFull.

He probado en 8 diferentes entornos/plataformas y solo me ha fallado en uno, un Linux con Kodi 19. Lo curioso es que en una rPI que tengo con la versión 10.0.2 me ha ido bien. En cualquier caso he subido una corrección para el 8º entorno que fallaba y ahora todos van bien.

Por favor, con el debug de Alfa activado reinicia Kodi y haz una prueba tanto con HDFull como con Dilo. Después me envías el log aunque te parezca que funciona. También me envías el fichero /storage/.kodi/userdata/addon_data/plugin.video.alfa/cookies.dat

El problema con la reproducción de la película ya está resuelto.

Muchas gracias por la ayuda.

Bueno, pues he reiniciado y no me ha dejado entrar en ninguno de los dos canales.

Adjunto el log y el cookies.dat

Un saludo
 

Adjuntos

hobbes

Usuario
18 Nov 2017
105
19
18
Actualizo con un nuevo log.

Despues de los intentos fallidos con HDFull y Dilo he intentado ver algo, primero utilizando la opcion de tengo una url y despues en diferentes canales, ha resultado totalmente imposible, errores y/o contenido vacio en todos los canales en los que lo he intentado.

Saludos.
 

Adjuntos

Kingbox

Miembro del equipo
24 Oct 2017
1.732
491
83
Madrid
Creo que tenías un problema masivo en tus comunicaciones (router, ISP, ...). Algunas veces entraba algo pero al momento volvía a fallar.

He revisado en profundidad los procesos involucrados. He realizado algunos ajustes, pero no tengo claro que eso arregle tu problema. Reinicia y haz otra vez la prueba como la vez anterior.
 
  • Me gusta
Reacciones: hobbes