Cuelgues o retardos de minutos al añadir pelis a videoteca

11 Dic 2018
52
2
8
40
#1
Hace unos días q me pasa y al añadir un peli desde newpct1 (no sé si en otros canales pasará) o se cuelga al añadir a la videoteca i se tira varios minutos en modo ocupado. Dejo el log a ver si veis algún fallo( espero q si). Gracias de antemano

Uploadfiles.io - LOG11181004.log


Enviado desde mi iPhone utilizando Tapatalk
 

Kingbox

Miembro del equipo
24 Oct 2017
592
206
43
Madrid
#2
Lo que aparece en el log es que la pantalla con los enlaces a los vídeos se refreca muchas veces, cuando se deberían refrescar sólo una después de que se añada la peli/serie a la videoteca. Esto es una función de Kodi. El problema que he visto alguna vez es que por conflicto con algún otro addon, típicamente en la sincronización con Trackt, repite esta operación muchas veces, pero en realidad el la peli/serie quedó añadida cuando apareció la ventana anunciando que se había añadido a la videoteca.

Mi sugerencia, es que si después de añadida la peli/serie empieza a dar vueltas la ruedecita, tranquilamente sales de esa pantalla aunque de un error el addon, pero en realidad la peli/serie se ha añadido bien y el error no tiene importancia. Otra opción es desactivar Trakt...

Otra cosa importante es que el parámetro <memorysize>419430400</memorysize> de Advancedsettings.xml está muy alto y apenas deja memoria libre para los add-ons. No me sorprendería que fuera la causa de este comportamiento de Kodi. Piensa que Kodi asigna buffers con el valor de este parámetro x 3. Eso deja muy poca memoría libre. Te recomiendo que lo bajes a <memorysize>367001600</memorysize>
 
11 Dic 2018
52
2
8
40
#3
Lo que aparece en el log es que la pantalla con los enlaces a los vídeos se refreca muchas veces, cuando se deberían refrescar sólo una después de que se añada la peli/serie a la videoteca. Esto es una función de Kodi. El problema que he visto alguna vez es que por conflicto con algún otro addon, típicamente en la sincronización con Trackt, repite esta operación muchas veces, pero en realidad el la peli/serie quedó añadida cuando apareció la ventana anunciando que se había añadido a la videoteca.

Mi sugerencia, es que si después de añadida la peli/serie empieza a dar vueltas la ruedecita, tranquilamente sales de esa pantalla aunque de un error el addon, pero en realidad la peli/serie se ha añadido bien y el error no tiene importancia. Otra opción es desactivar Trakt...

Otra cosa importante es que el parámetro 419430400 de Advancedsettings.xml está muy alto y apenas deja memoria libre para los add-ons. No me sorprendería que fuera la causa de este comportamiento de Kodi. Piensa que Kodi asigna buffers con el valor de este parámetro x 3. Eso deja muy poca memoría libre. Te recomiendo que lo bajes a 367001600
Ok. Lo del trakt puede ser porque estuve probando diferentes opciones,y había un par de ellas de sincronizar cuando añades películas. Una vez desactivada la estas opciones he probado a añadir varias pelis activando y desactivando el trakt( desde los ajustes de alfa) y no hay diferencia de tiempo. Lo del tamaño del buffer si es verdad q es muy alto. Se q tiene q ser un tercio de la memoria libre q tenga. Suelo tener entre 1100 y 1200 megas libres de memoria,y a ser libreelec no suele bajar nunca de ahí. He puesto 360 ya q uso el ftgmaint y en vez de poner todo el numero largo q has puesto( entiendo q es el valor multiplicado por 1024) y en el advanced settings aparece como 368xxxxxx( te lo estoy diciendo de memoria). He hecho otro log por si no es mucha molestia q le eches un ojo a ver si se siguen viendo cosas raras. Activando o no el trakt y con ese valor de buffer,tarda unos 30 segundos por peli cada vez añado una. No se si es normal o debería tardar menos. Lo q comentas de darle a escape cuando ya ha añadido la peli,lo hago a veces,ya q desde q sale abajo q la peli se ha añadido hasta q se termina el proceso,es cuando tarda en cargar esos 30 segundos. Dejo el log por si le puedes echar un ojo,a ver si hay algo más q se pueda hacer. De todas formas,muchas gracias una vez más por la paciencia y los consejos...
Uploadfiles.io - LOG502008108.log


Enviado desde mi iPhone utilizando Tapatalk
 

Kingbox

Miembro del equipo
24 Oct 2017
592
206
43
Madrid
#4
La situación es similar. Kodi repite el refresco de pantalla muchas veces. Eso no lo pide Alfa, lo hace Kodi provocado por alguien, pero no creo que sea Alfa directamente. Lo que si sigue por medio es Trakt.tv, pero perfectamente puede ser el culpable.
 
11 Dic 2018
52
2
8
40
#5
La situación es similar. Kodi repite el refresco de pantalla muchas veces. Eso no lo pide Alfa, lo hace Kodi provocado por alguien, pero no creo que sea Alfa directamente. Lo que si sigue por medio es Trakt.tv, pero perfectamente puede ser el culpable.
Probé a desactivar la opción de trakt desde los ajustes de alfa,pero como bien dices el problema sigue igual. Probé a desinstalar el trakt y entonces la espera al añadir una peli se redujo a la mitad(15 segs como mucho). Ahora instalando de nuevo trakt con los ajustes predeterminados,el tiempo no se amplió. Yo ya no se,si aún así sigue repitiendo el refresco de pantalla,pero juraría q mas o menos es el tiempo q solía tardar por lo normal. Si no es abusar de tu tiempo,q me da q si,te dejo el último log y prometo no dar mas la vara. Si aún así,sigue refrescando mas veces de la cuenta,tendré q buscar otras opciones ya q como te digo el tiempo actual es el mismo q con el trakt desinstalado. De todas formas no se me ocurriría q mas hacer,salgo probar con el skin básico de kodi,q este q uso ya me había dado un problema parecido a la hora de abrir pelis de la videoteca. Una vez más,te agradezco tu trabajo. Prometo q este es el último log...jeje!!!
Uploadfiles.io - LOG724089163.log


Enviado desde mi iPhone utilizando Tapatalk
 

Kingbox

Miembro del equipo
24 Oct 2017
592
206
43
Madrid
#6
Probé a desactivar la opción de trakt desde los ajustes de alfa,pero como bien dices el problema sigue igual. Probé a desinstalar el trakt y entonces la espera al añadir una peli se redujo a la mitad(15 segs como mucho). Ahora instalando de nuevo trakt con los ajustes predeterminados,el tiempo no se amplió. Yo ya no se,si aún así sigue repitiendo el refresco de pantalla,pero juraría q mas o menos es el tiempo q solía tardar por lo normal. Si no es abusar de tu tiempo,q me da q si,te dejo el último log y prometo no dar mas la vara. Si aún así,sigue refrescando mas veces de la cuenta,tendré q buscar otras opciones ya q como te digo el tiempo actual es el mismo q con el trakt desinstalado. De todas formas no se me ocurriría q mas hacer,salgo probar con el skin básico de kodi,q este q uso ya me había dado un problema parecido a la hora de abrir pelis de la videoteca. Una vez más,te agradezco tu trabajo. Prometo q este es el último log...jeje!!!
Uploadfiles.io - LOG724089163.log


Enviado desde mi iPhone utilizando Tapatalk
Sí parece que lo repite dos veces, cuando debería repetirlo solo 1. Los skins a veces dan problemas. Es buena idea probar con el skin estárdar.